ProServe 2012 - Software Solutions for Pest Control Companies

 

Office (205) 467-7427
Springville, AL USA

What is the New G2 Version

The new ProServe 2012 G2 (2nd Gen) Version is the same product as the release of ProServe 2012 as of 08/31/2018 v1.0.43 as far as the current features are concerned. ProServe 2012 was originally designed and deployed for Microsoft Windows 7 with the .NET 3.5 Framework and SQL Server 2008 platforms. Well, as you know Microsoft will always move forward with new operating systems and .NET platforms. So, I must keep up if I expect to continue selling my product. Basically, the new G2 v2.x.xx series is targeted to the latest Windows 10 (64bit) OS running .NET 4.7 Framework and the SQL Server 2017 platforms. See below for a bitter understanding.

Target System Requirements:

ProServe 2012 G2 v2.x.xx Series Requires:
  • Windows 10 or higher (64bit)
  • .NET 3.5 Framework (already running on Windows 10)
  • .NET 4.7 Framework (already running on Windows 10)
  • Windows 8.1 to the best of my knowledge can run .Net 3.5 and .NET 4.7 but may not be enabled by default.
  • Both Windows 8.1 and Windows 10 must be 64bit OS
  • Work Stations (client) Windows 7 SP1, 8.1, 10 and up (32bit or 64bit OS)
  • SQL Server 2017 Express is the target database platform.

ProServe 2012 v1.x.xx Series Requires:
  • Windows 7 or higher (32bit or 64bit)
  • .NET 3.5 Framework
  • SQL Server 2008 Express is the target database platform.
  • SQL Server 2012 would work as long as .NET 4.5 or 4.6, 4.7 was also installed and running.
    (in most cases so far this version of ProServe 2012 will run on Windows 10 boxes without any problems)
  • SQL Server 2012 is the limitation of this version.

Should you be concerned?

The original release of ProServe 2012 and the new release of ProServe 2012 G2 are totally separate software products, they are developed and maintained in two different development environments. The first was developed using Visual Studio 2008 on a Windows 7 box, the second edition of ProServe 2012 is developed using Visual Studio 2017 on a new Windows 10 computer. So, with that said; the new edition of ProServe 2012 (G2) will become the core product that I will market for future clients running Windows 10 or higher, although I will continue support for the v1.x.xx sires. But, future enhancements and features may or may not be implemented into both editions. Most likely only bug patches will be implemented into the previous edition. 


Should you upgrade?

Yes, you should upgrade if you can. You must be running Windows 8.1 or Windows 10 or higher to upgrade. If you’re not; then continue running what you have because I’m still supporting the v1.x.xx series if users are still running this edition. While keeping in mind that this edition may not install on future Windows operating systems.

What is the cost to upgrade?
  • Single User Upgrade - $145.00
  • Network User Upgrade - $75.00 per user.
  • Requires Remote Desktop Service into each computer to complete the upgrade.

Please call the office at 205.467.7427 to setup an appointment.

The rates above cover for my time, it could take at least an hour or more to complete. It will only require your attention initially for up to 10 minutes and then you can go on your way, by the time you return you will be running the latest edition of ProServe 2012.